[WIP] Won't track steps from phone

Hi @Afisis, can you please pass me your new ID? I can transfer the data for you.

In terms of the steps issue. Are you using iOS or Android? And are you syncing with phone or Fitbit?


My new ID is MPV4BPhp!. I have Android and I am syncing with phone.


Hi @Afisis, your data has been transferred. Please let us know if you have any other issue.

The Android pedometer bug is a tricky one as we cannot reproduce it from our end. We’ve submitted a build which enables more log for us to spot where the issue is. We’ll let you know as soon as we make any progress.


Hi @marspark. Unfortunately there’s still no update for Android. And my steps counter is still stuck. So I’m looking forward to a fixing update.
Thanks for your support.
Edit : BTW., I’m not using fitbit but my built in health software to count the steps.

@Fluffy we’ve submitted a build last Friday which should go live early this week. We’ll probably need your help to enable the new log functionality to see where is going wrong with your pedometer functionality. Anagin thank you very much for your patience and support.

您好,已經可以正常計步了!這讓我跑步的動力又回來了!太感謝您們了 :smile:

1 Like

I’m also having trouble getting steps to sync from my phone. Google Pixel running Android 7.1.2.

I have the same problem, I’ve had the game for about a month now. I have the iPhone 7.

Hi @LittleCat please install our latest version 2.2.6 which has just gone live today.

Hi @Ruru can you please try to download our latest version (v2.2.6) which has just gone live today. If you are still having this issue, please let us know and we can troubleshoot with our enhanced log system. Thank you!

Hi @marspark. I downloaded the new version (v2.2.6) as you advised me in a different topic that is now closed, but the step counting system is still not working. Could you take a look at what is going on, please?

Same here. iPhone 5s, IOS 10.3.1

Hi ZmanRockz,

Could you check if you have given the game access to the ‘Motion Activity’ on your iPhone? The steps will not be tracked if you didn’t authorize the access.

Please go to iPhone settings > Privacy > Motion & Fitness, and make sure you have authorized access to Pocket Plants. Please refer attached for details.

Please let me know how you go with this. Thank you!

Motion and Fitness was turned off. Thanks!

1 Like

hi there, I’m still having issues with step tracking. In the day at work i do at least 10k steps but none of them are tracked. When i get home in the evenings, steps are tracked occasionally. I do check the app a couple of times during the day but nothing is tracked. Game version 2.2.6 running on Android 6 device huawei p9 eva-L019. Tried the fixes mentioned here but nothing has worked.

Make sure pocket plants is closed. Walk. Finish your walk in the phone app. Close the phone app. Open pocket pants. Your steps should be there. Watch the video to increase your steps.
Complicated, yes. I lost a lot of steps before I figured this out.

1 Like

I have the Samsung J5 2017 android version 7.0 is it compatible?

My phone isn’t tracking steps either. Oppo 9, android version 7.1.1. App is not linking to ready body data in app permissions.

Samsung Galaxy S7, game will not track steps though it’s running in the background

@PNW420 Hi, thank you for reaching out. Can you please check if you’ve done everything in this post: Troubleshooting - Track steps using Android devices? It’s from another game but we are using the same mechanics.