iOS V3.1.8 stuck issue updates


#1

Hi guys,

Please update to V3.1.10 to resolve the 85% stuck issue.

If it’s not appearing in your update list, please search “Fitness RPG” in AppStore.

Also kindly leave your game id if you were affected by the issue to receive compensations.

We’d like to say a huge thank you all the players who have participated in the beta test to resolve this tricky issue. The crash/stuck is due to how your local calendar converts the date format which is no longer compatible with our upgraded coding program. If you are seeing anything weird related to the timers (shop refresh, daily challenge resets, etc), please let us know!

[compensated status] Affected users

Thank you again for your patience and really sorry for any inconvenience caused.

Mars


V3.1.8 Release Notes
#2

Log instructions: thank you thank you thank you for helping out!!

  1. Tap center-left corner 3 times, very fast. It should show a console
  2. After it gets stuck at 85%, screenshot the log
  3. If the top right has a number beside the red dot (warning), tap the dot, then screenshot the warning



#3

Great to hear! I purchased my super mega pass, and I paid it via App Store!!! So we continue w/beta testing or nah?!


#5

Yes, the beta will continue to run until the 85% stuck is fixed. Are you in the game now? Please let me know your game id if you’ve bypassed the 85% issue.


#6

@marspark I am able to restore my old progress and play via the TestFlight app! You and the team are phenomenal!!!

I am having an issue with the SuperPass though. My superpass is active until the 8th however the TestFlight app does not register that it is active.

I tried purchasing the mega pass but it seems to be stuck in a loop asking for my Apple ID password to confirm the purchase. Tried entering my password several times but the trial never activates


#7

No worries, I’ve just sent you the SuperPass. Please reopen the game to enable it. The compensations will follow after I’ve confirmed with our game designer!


#8

Hi @marspark ,
Looks like I wasn’t connected to game center and I’m definitely not connected to Facebook.

Are you able to restore my account? Both old and new username are maebi

I think the old server might have been twin peaks or something I can’t remember.


#9

Did you need my game ID for compensation? Let me know :slight_smile:


#10

We’ve just uploaded a new build, do you want to try that 1st?


#11

Yes, please let me know your game id


#12

G9bq5q is my ID thanks, yes I will give it a try!


#13

New update working great !


#14

Can you please confirm that you were previously stuck at 85%, and now able to enter the game? You didn’t try to sync your data from the cloud right?


#15

I was stuck at 85% or 87% and I connected my account through facebook


#16

@marspark
Thank you and your team for all the work you have put into this app.
My Fit Land id r6b43q. My Fit Tower id xj6x74. My Twin peaks I’d znpm7x.
Thanks again for your continued work on this great game.


#17

Yes, thanks for your quick response :raised_hands:t2:!!! So, I had test flight for other apps, geared towards blogs, so when I saw your link, i had no issues whatsoever!!! I can log in and play as I normally would!!! One question though, I am not able to save my progress thru Game Center, is there a preference on which server I’d save my info? And finally, I LOVE THIS GAME! You’re forum is amazing as the OG players, lol, guide us newbies… I’m just full of questions and is there a post that I can read? My concern is I’m a leader of our guild, as no one was active…so frustrating…suggestions anyone!!! Thank you @marspark!!!


#18

Hi @roXstar, are you saying that the latest build solved 85% issue? Or did you bypass the issue by reinstalling the app and pulled data from cloud?

Also, please leave your game id so I can send over the compensation!


#19

Hi, xj6x74 doesn’t seem to the correct short id, can you please double check it for me? Thanks!


#20

@Ivyh did the new update fix the issue? I couldn’t find accounts under the nickname maebi. Can you please double check it for me (case matters too)


#21

@tnv_30 couldn’t find accounts under these names. Can you please give the new TestFlight build a try and see if it fixes the problem? Thanks!