Troubleshooting - Track steps using Fitbit

1. Log steps in Fitbit first then return to our games.
2. Try switching internet connection if it doesn’t work.

Checklist:

[1/3] Please make sure the steps are logged into Fitbit dashboard or Fitbit app

[2/3] Now try to wait a little bit and open Fitness Fantasy, it may take a few tries

[3/3] If it still doesn’t work, please try again with a different internet connection

A good internet connection is essential for uploading your Fitbit steps to the Fitbit server and allow our games to sync them to the game.


If you haven’t connected Fitbit, please check this page:

Is there a Fitbit bug as my charge HR is not syncing for the past 2days using a iPhone 7

Hi @Jess_Jones, does any other Fitbit compatible apps works with sync?

Having difficulty with the game tracking my steps using my fitbit flex. I am stuck in the beginning where it ask for you to walk 10 steps and i did then when i tried to click back it is still on the walk 10 steps screen I cant close the app because then it starts me all over where i must choose again and then the problem repeats. I am sorry if I wrote this in the wrong spot I am not really forum savy.

@badaxe thank you for reaching out. Have you tried to sync with the fitbit app first under a good internet connection?

I uninstalled and then reinstalled and the issue was resolved thank you for your rapid response

I never had any trouvle with my fitbit charge 3 maybe it because I set it on always sync.

Master code: d5wgy (power tablet server)

1 Like

@marspark I have tried different server but no success. How can I check that I am connected to the Fitbit? Still no steps coming through
Even if they are on Fitbit app

Please click Fit Savior -> Device
image

Thanks so much. All my past steps have now come through!

1 Like

Hello- is there a way to switch how your steps are tracked once you’ve already begun a game? I started using with my phone but just got a FitBit Inspire and I wanted to use that to track my steps for the game now instead. Is this possible?

Hi,

Sure, you can switch the tracking device in Fit Savior (the character) → Devices (last tab)

Last couple days fit rpg is not syncing my steps. Fitbit app is updating regularly with no issues.

Tried troubleshooting tips with no success