Game stuck on checking for updates when opening

I have been stuck on 8% loading status: checking for uploads for several minutes. I tried restarting my iphone 7, looking for updates for Fitness RPG in the app store and nothing. I’m worried that if I try to delete and re-download the game that I will lose all the progress I have made. Any ideas?

1 Like

Same problem here. Closed game, restarted phone, and deleted and reinstalled the game. Still stuck at 8%.

Same here! Oh good, I’m relieved though, it’s not just me. Server issues. It’ll be back up eventually.

1 Like

@marspark Can’t get into the game either :thinking:

1 Like

Hi guys, there’s a minor issue with the server which we just patched it urgently. You can now login and we’ll send over some crystals for appreciating your patience~


@marspark Thanks for fixing the problem so quickly.

1 Like

Hey, same issue, but I uninstalled and reinstalled the game and lost all my progress. How do I recover my account?

1 Like

Thanks for fixing the initial problem quickly! I received the crystals but now opened the app to find my progress gone. Please help @marspark

Hi, have you connected to any 3rd party account? If so, you can connect to the same account again and please make sure to choose ‘cloud’ when a data conflict window popups up.

Hi, have you connected to any 3rd party account? If so, you can connect to the same account again and please make sure to choose ‘cloud’ when a data conflict window popups up.

@marspark I wonder if it’s possible to sync data from all 3 servers to FB. Currently my latest account is not syncing to anything :thinking:

I don’t have the cloud as an option, but yes, I’m connected via Facebook and Game Center.

It’s still not syncing to my account. I’ve got it connected to Google play and my new id is: z82kbv. If it helps I had a friend take a screenshot for me

@artemis512 @Lilnikkel @Rain

Hi, you guys may have entered a new server after reinstall. Any newly installed players will be directed to server 3: Twin Peak and you need to jump back to server 2 to resume your progress. Can you please check if you can retrieve your data on Fit Tower? Please choose settings -> select server and select ‘Fit Tower’. Please make sure to choose ‘Server’ when a data conflict window pops up.

1 Like

@marspark: thank you for your reply.

For some background, I had a level 290 character on one server, a level 60+ (probably much higher but I can’t remember) on another server, and a level 33+ character on the newest server.

I couldn’t change server until I went through the tutorial again, so I did this a minute ago and left the character name as Olaf.

After that I followed your instructions and changed the server to Fit Tower. So it reverted my character to Hawtpeas, at the beginning of the tutorial.

I really hope we can figure this out


I just flipped through the servers, and my level 290 character is gone. Here are the characters on each server, currently (see pictures).

I am trying not to feel ill. :nauseated_face:

I realized that I had been using the wrong terms (character instead of player). So, just reminiscing… Artemis player account was level 190+, I believe, with my 4 main team characters each at level 290. Artemis was active since beginning of May 2018, and I’d gotten in league B. I was in guild ButtLosers.

Is there any way to look for my highest level player/account named “Artemis”? If it’s not recoverable, I will likely unsubscribe. :confused:

Edit: I found my Facebook group post when I was searching for an apprentice. Maybe the master code can help? See picture attached.

Hi @artemis512, can you please connect your Facebook account @ Fit Tower? Please choose ‘server’ when the data conflict window pops up. Please let me know if you cannot retrieve your data.

Hi Rain, you can connect with the same Facebook account across all 3 servers.

@Lilnikkel hi, have you tried to connect to Google Play after switch to Fit Tower server? Your Fit Tower account is still tied with Google Play.