Won't fetch steps from fitbit

Hi, I’ve been having problems fetching my Fitbit steps. It did upgrade the first time I connected with the app, but it never synced afterwards. Could you please help me with this issue? I’m using iOS 10.2.1 and my game id is FC+7xEzQp. Thanks a lot!

Hi Juni,

Which country and time zone are you in?

I’m in the United States, central time. And actually the synchronization works fine now.

Thanks for letting us know! We are also preparing an update to improve Fitbit syncing issues. Please stay tuned for that and let us know how you go with it. :slight_smile:

My steps have only synced once since downloading the game almost 2 weeks ago, this was after the initial connection authorisation of my Fitbit. I have the most up to date version of both the Fitbit and pocket plant apps, I’ve tried disconnecting and reconnecting the Fitbit from PP, I’ve even unpaired the tracker from the Fitbit app to ensure it’s not a Bluetooth issue, nothing seems to be helping. I still only have 12 steps despite doing 60k this past week.

F3CntpD4g is my game ID I’m on an iPhone 5s iOS 10.2.1

Hi VisionaryDecay,

Have you synced steps in Fitbit before trying to fetch them in Pocket Plants?

Yes, that makes no difference either. Not being able to get steps is starting to hold back my game progress as well as I can only collect gems is from completed orders to unlock new plants. I would really appreciate it if something could be done to fix this issue.

Hi VisionaryDecay,

Sorry for the late reply. We spent quite a lot of time trying to figure how the issue, however, our Fitbit device works fine and couldn’t reproduce the problem on our side. While we continue our investigation, could you try to revoke the Fitbit authorization and re-authorize Pocket Plant again to see if that would solve the issue?

To revoke authorization:

  1. Go to www.fitbit.com and log in
  2. Go to Account settings (top right icon on dashboard page) > Applications
  3. Find ‘Pocket Plants by Shikudo’ and revoke access

Reconnect Fitbit after revoking access in Pocket Plants:

  1. Please make sure Pocket Plants is removed from background
  2. Go to Connect page and you should see the Fitbit authorization is failed
  3. Tap Fitbit button to initiate the re-authorization process
  4. Please make sure you tick the ‘activity and exercise’ box when the Fitbit authorization window pops up
  5. Tap allow button and follow the prompt to go back to the game

Please let me know if Fitbit is working using this method.

Thank you!

Hi there, I tried this solution early but it unfortunately hasn’t made a difference.