Troubleshooting - Track steps using Google Fit


#1

1. Log steps in Google Fit first then return to Fitness RPG.
2. Try switching internet connection if it doesn’t work.

Checklist:

[1/5] Please make sure the steps are logged into Google Fit

[2/5] Click Profile -> Settings -> Manage connected apps and make sure Fitness RPG is there

[3/5] Now try to wait a little bit and open Fitness RPG under a stable internet connection, it may take a few tries

A good internet connection is essential for uploading your Google Fit steps to the Google server and allow Fitness RPG to sync them to the game.

[4/5] If it still doesn’t work, please go to Phone Settings -> Apps -> Google Play Services -> Manage Space/ Storage -> Manage Space option -> Clear All Data

[5/5] If you are still having troubles with tracking steps, please try to clear all the Fitness RPG app cache and data re-downloaded the game.


How to track steps with Google Fit?
Steps not being tracked
Having issue tracking steps?
#5

Give me 10 steps please i don’t continue the game i engouht the steps


#6

Quiero 10 Xq No Puedo Seguir Jugando


#7

@11131 Please make sure you go to the Google Fit app first and confirm the steps have been added to the app, before coming back to Fitness Fantasy game and get those steps.

Please let me know how you go with this.

Thanks,
Ally


#8

Do you have any Google Fit issues? Please make sure your steps is synced in Google Fit app before returning to Fitness Fantasy game.

Thanks,
Ally


#9

Hi there, I’ve been having multiple tracking issues lately, sometimes 9000+ steps from Google Fit don’t get synced to Fitness Fantasy!
I made sure that my Google Fit had the steps, changed the internet connection, etc., and I still get nothing :frowning:
This has been a pain for a while now


#10

Hi,

We are now preparing a new build to fix a few Google Fit issues. I’ll let you know once it’s ready and please have a try. I’ll also send over some compensation for the trouble you went through.


#11

Wow thanks! I’ve seen my steps from earlier days registered to the game.


#12

I’ve been unable to get past the initial screens, because the app won’t sync with Google Fit. I have followed all of the instructions included in this whole thread and had no success. I’ve been trying to get this to work for about a week now. Please help. Thanks!


#13

@jllaughl do you mind to send me a screenshot of your Google Fit step page?


#14

I am having an issue switching from game tracking to google fit. Do i need to be awake at midnight to do the switch? It says that the switch happens at midnight, amd gives a countdown, but then it seems to give up on the countdown shortly after. I scheduled it to switch last night and it did not.


#15

@Changer it should switch automatically. Is it not the case?


#16

Twice in a row now, it has not. Last night i stayed up til midnight, and initiated the switch five minutes til and did not touch anything. When it hit midnight the timer rolled over to 24 hours and did not change to the new tracking method.


#17

Can I please grab your id? I’ll check your data


#18

My id is zv775k, i managed to get it to switch last night by scheduling the switch, closing the game immediately and not touching it until after midnight.


#19

This is not working for me. I have tried all of these steps, and it does not being my steps offer from Google fit.