Steps not syncing on iPhone

I’m having trouble with my steps not syncing from my Apple Watch to the game. Everything was working fine last week but this week I’ve got no steps registering. I was wondering if anyone had any ideas?


Thank you for reaching out. Have you tried to reinstall the game? Please remember to connect to a 3rd party account before uninstalling the game. Once you reinstall the game, select your server in the settings then connect to the same account to retrieve your progress (you can also record your game id just in case).

I’ve just tested the integration and it works fine on our end. Please let me know how yours going.


Hello…can I login from tablet and mobile at same time for sane account???

Thank you for reaching out. Yes you can, 1. bind a 3rd party account in settings, 2. connect to the same account on your other device, your progress will be synced over

Hey. I’m having issues syncing steps as well. Using Fitbit and the app just randomly stopped syncing. Never had issues before and this stopped when the app switched to a new day. I did uninstall reinstall with no luck. Any other options or maybe someone can look into my account?



Mirror lake

Hi @C-Bass, have you tried to revoke Fitness RPG’s access in the Fitbit dashboard? Once this is done, click the Fitbit button in the Devices tab and it should take you to a Fitbit page to type in your credentials.

If this still doesn’t work, revoke access → reinstall fitness RPG → connect.

Please let me know how it goes!

Not at all working…I always login via Facebook account…when I reinstalled the app in phone …all my progress are gone

Hi, you might have joined a different server. Please check your server name on your tablet, then select the same server (settings → select server).