Step counter throttled to one step per second (android)


#1

Anyone have any idea why, since last week, the step counter in wokamon detects exactly one step per second, regardless of how many actual steps I take per second? It seemed to happen right after I installed Google Fit. Perhaps doing that updated some shared step counter api on my phone (Galaxy S8) that Wokamon is incompatible with? I tried uninstalling Fit, Wokamon, and clearing the Wokamon data cache. My version of Android apparently doesn’t have any Motion settings that I can check. Any other ideas would be appreciated.


#2

I guess the reinstall doesn’t work. Have you tried to connect to Google Fit again and see if it can fetch steps from Google Fit rather than your motion API


#3

Yes, I ended up uninstalling and re-installing Google Fit, and at some point, Wokamon began fetching steps from Google Fit successfully! The fetch option works great now. Thanks!