Phone changed, can't recover my account

Hi, please I need help. I have an account with a lvl 130+ character, and I’m a guild lvl 5 leader. I connected my account to Google Play but changing my phone device the app want to assign me a new account. How can I restore my account and all my progress/guild?
My “old” Eretica ID: rgmpkj server: fitTower

1 Like

I just had the same problem and found a solution… To sync your progress between the devices, from the game’s settings on your new phone you have to open “change server” and select exactly the same server you play on your old phone (fit tower). Then, after you re-open the game and finish the tutorial intro, you can open the settings again and it should give you an option to sync with google and facebook again. It will ask then if you want to continue using local or server data, choose “server data”.

(It looks like the game automatically generates player account to the newest server (twin peaks) after you install it, but you can have accounts on all 3 servers and switch between them, syncing each of them separately).

1 Like

Thank you Camoghost, but I tried your suggestion yet, with no success. I saved my data on Google and FB, and saved them using my old phone again today but when I reinstalled the game in the new phone connected to my G account (and after another long, boring damned unskippable tutorial) in server setting no account result on FitTower.
No way to recover my account, and the staff seems to ignore me.

My saved data

New account created by the system

No account on my old server FitTower

I know this is an old thread, but maybe it will help someone else.

I did as Camoghost suggested, but at the last step, it asks first if I want to use local or server, then it loads the server and immediately asks again. The second time (squinting to make sure it was my sync username, not Olaf) I chose local.

It seems like the server has a little trouble verifying because (maybe?) it switches the newly created local account to the server and the server account to local when you choose server the first time.

Anyway, that worked for me and I hope helps someone else. This worked as of today, but might change with future updates.

1 Like

Hi @Eretica, extremely sorry for missing your post! Not sure why this has slipped off my rader. Are you still having issues accessing the account? Please let me know (you can send me an email at for a faster respond).

Hi, I finally retrieved my account, but now I have another bug that make the game almost unplayable.

After the shift to wintertime on the last Sunday in October the game seems to have been desynchronized: it goes on for a whole day, assigning the results of the present day to the previous day.

I don’t know if this problems are related to main one, so I’m going to open another post about this.

@Eretica replied on another post

1 Like