Not Updating Steps - Google Fit

After the most recent update to my Pixel 2, Fitness RPG suddely stopped importing steps from Google Fit. I have made sure that Fitness RPG has the correct permissions and have tried uninstalling and reinstalling the application with no luck.

Hi, thank you for reaching out. 2 things you can try:

  1. Click the Google Fit tracking option again, it will try to resync if there’s an issue with the authentication.
  2. Can you please try to switch to another tracking option and after a day, switch back? You can send your game id to us so we can give you some compensation for doing that.

Please let us know!

1 Like

Thank you for the suggestions, I tried connecting with Google Fit again without success. I have now switched to the phone step tracking option and will see if that works tomorrow as it has a delay. My ID is: jg7n4b.

@marspark Switching to my phone’s step tracking instead of Google Fit has resolved the problem and I am able to track steps now! Thank you for the assistance! Would it be possible to have steps added for those missed days? (01/23 - 01/27) My ID is: jg7n4b

Thank you again for the quick response!

1 Like