Lost Fitbit steps / now won't connect

I had saved up 20k Fitbit steps… Went to go use them… And they had disappeared… I tried disconnecting and reconnecting the Fitbit and reloading the game numerous times but no use. And since then it will not fetch my steps. Any help would be appreciated because Eth’s is very frustrating… :-(. My file name of the game is MP*~N7nKg

1 Like

Sorry to know you are having issues with Pocket Plants.

Did this happen before? Were you able to save up to 20K steps and convert them into other in-game currencies successfully? Is Pocket Plants still connected to your Fitbit? Are you able to send us a screenshot of your tracking connection page in the game?

Do you remember anything specific you did before the incident? Like clear cache or anything like that?


1 Like

Hi there. No I did not clear anything. I upgraded from 20k to 30k. Closed the game to continue walking. Went home and was going to spend the steps and they had vanished. How do I go about sending a screen cap? The Fitbit says it’s connected on the game but still won’t fetch the steps even after syncing with the game…

Also no it has never happened before. I have converted small amounts with no issue before. This is the first time they have disappeared.

Our devs are looking into the issue right now. I will get back as soon as we find anything. In the meanwhile, could you send us a screenshot of your ‘Connect’ and ‘Convert’ game page and let me know which resource you were going to convert with the 20K steps. I’m going to manually convert them for you.

1 Like


Please don’t worry sending over the screenshot. Please let me know which resource you would like, and I will manually convert the missing steps for you.


Oh that’s very kind of you… I would just appreciate the 20k steps I walked and a way to sync my steps once again. Do you have any suggestions?

I was going to convert it to amethyst. I am at the power up level which would give me 276 amethys for 20 k steps.

I have manually converted the steps for you. Please claim the resource in Pocket Plants message page.

Could you check for me if your tracking option has a green tick next to Fitbit and displays ‘CONNECTED’ under it? If no, could you tab the Fitbit icon to reauthorize Pocket Plants and see if that helps to sync the steps properly? (please refer attached image)

Please let me know how you go with this.

Thank you so much I got them :heart: for some reason my Fitbit is properly syncing this morning… So roblem solved for now! Thanks again!