How to sync with GoogleFit

Step One : Go to Settings -> SYNC OPTION -> GOOGLE FIT

Step Two : Choose your Google account

Step Three : Click on the left corner of the main page to sync with Google Fit

1 Like

Hi, i have a LG G5 and using LG Health for my steps. I connected LG Health with google fit, downloaded google fit, and synced wokamon with google fit but it just won’t sync… And now wokamon even doesn’t count my steps at all anymore! How can I fix this?

I have the same problem too help me!

Same problem. Not only does it not Sync with Fit but it seems its not tracking anything (I’ve run 5k yesterday and it only tracked 293 steps…)

Found a fix to the problem of downloading google fit after setting it to synce with it.

  1. Unsync google fit in Wonkamon (Just make it use your phone)
  2. Go to google fit > Profile > Settings > Manage Connected Apps > Find Wonkamon and Click > Disconnect.
  3. Go back to Wokamon and sync it again and it should ask you to log in to your Google account again.
  4. Done! Hope someone finds this helpful.