Glitch after unlocking "Sea" World!

Hello! I recently found Pocket Plants and I fell in love with it! Sadly after playing it for a few days, the app would not work for me!

To give more details, once I open the app, I am on my main plant page but on the bottom, the king is there and says “Are you ready for some new challenges?” and only tappable thing is the arrow pointing to the right. When I click it, it transfers me to the next screen which is the “Sea” World. Then the screen freezes but the music continues to play. I am unable to click anything at all.

Can someone please please please help me fix this glitch? I already tried uninstalling and reinstalling. I also tried to close and reopen the app. No luck! :sweat:

Thank you guys!

Hi Aurosia,

How many worlds have you finished collecting?

Do you connect to Google Play / Game Center/Facebook/Kongregate to save your progress? When you reinstall the game, is there any pop-up window asking you to choose ‘Cloud’ saved data or ‘Local’ saved data? Which data did you choose?

Are you able to get a game ID so that we can try to take a closer look?


1 Like

Thanks for responding!

I have only collected one world which was the started. I barely unlocked the next world and then the glitched started!

I also am connected to the Game Center (ID: jaannyz). Whenever I reinstalled the game, I would choose “Cloud Save Data”.

Let me know if you have anymore questions!

Which apple device and iOS version are you using?

I have the iPhone 6s and iOS 10.2.1!