Focus Session Fails to Complete

I’ve been missing out on focus rewards when I put my iPad to sleep lately. Not sure what changed.

  1. Set 5 minute focus. Take screenshot. Press physical sleep button on my iPad (upper left corner). Screen goes dark as expected.

  1. Wait a few seconds. Press home button. Game resumes where it left off and countdown timer continues to drop. Take screenshot. Press physical sleep button on my iPad. Screen goes dark as expected.

  2. Repeat step 2 as many times as I like. No problems encountered.

  1. Wait more than a few seconds (say 30 seconds or more). Press home button. Game resumes with the following oops. Take screenshot.

Here’s why it matters. If I set the session for 5 minutes, press the sleep button on my iPad, wait a full 6 minutes, press home button to bring iPad out of sleep mode, and then try to collect my 5-minute focus reward then I’m told the session was not completed. No reward.

I really want to be able to put my iPad to sleep to save battery power while I am focusing, especially if I’m focusing for 2 hours.

It seemed to work fine when I first started testing the app, but I’ve been having issues getting it to do that over the past 24 hours or so. Not sure what changed. Maybe I was doing something slightly differently? Or maybe the length of the focus session matters? :thinking:

The good news is that I can definitely recreate what is not working today. The steps I have outlined here seem very repeatable. I seemingly cannot set a 5-minute focus session, put my iPad to sleep for 6 minutes, and collect the reward when I wake my iPad back up.

1 Like

Hi, thank you for the detailed walkthrough. Ideally, you can lock your device for as long as you want and it won’t interrupt your focus session. We’ll try to reproduce the bug on our end!

1 Like

Hi, first of all, this app is amazing, even while it is still in development. It has helped me so much and I find it more effective than other study apps I’ve tried!

I found that I used to have this same issue (session ending after locking device) - it was fixed over the last few weeks but since the latest update, I’ve noticed that the moment my phone falls asleep, the session ends. I would really love it if I could leave my phone asleep while studying. I have an android phone, by the way.


@pucci thank you for letting us know. Just want to confirm that the issue was previously fixed but now returned with the latest update right? A few questions to help us with the investigation:

  • Are you using iOS or Android?
  • Have you allowed the permission?


Hi Mars,

Yes, that’s correct. It was an issue that was previously fixed but returned with the latest update. I’m using Android (Samsung s9) and I believe I’ve allowed the permission… but when I try to check in my settings, it doesn’t list any.


@pucci, please check with our latest update and see if it fixes your problem. Please let us know!

I am currently having this issue. I’m using Android (Google Pixel).
It was fine before the update to v1

Hi @Doomhamster, a few questions:

  1. Have you granted the permission?
  2. Does it happen when you ‘lock’ the phone?
  3. If not, can you please elaborate a bit more of what leads to the session fail?

I have granted the permissions required.

I’ve tried with different time lengths, all with putting the phone to sleep, with and without background sound, and it seems to only be when I set it to focus for 2hrs.
The last time I tried, the app stopped after 30 mins. I had to reopen the app, then had the option to watch a video to continue the session. I did that, let the timer start and put the phone to sleep again. The background sound lasted 30 mins, then stopped. I woke my phone to find the app had stopped again.

I’ve run the focus session for 1hr 55 and had no issues, even if I don’t check the app for over an hour after the end of the session. The bgm continues to play until I wake my phone.

Since the most recent update the focus session will now run for the whole 2hrs, but, if I don’t wake my phone in time for seeing it countdown to zero the app closes. When I reopen it, I get the option to watch an ad to complete the session which then has a timer of just zeros with the bgm playing. It doesn’t resolve. I have to quit the session and get no reward.

@Doomhamster thank you for the detailed clarification. We’ve been working on a update and will release it within the week

1 Like