Collecting Fit reward II


#1

I keep failing to collect reward II (the ones that require add viewing). Guessing it’s because I ran out of watchable adds. How do you guys deal with it? Not watching any adds until before midnight? Or…?


#2

I’ve never run out of watchable ads. Every now and then (rarely), some ads seem to skip the video part and go straight to the ad’s final ending that I still have to dismiss by clicking the close box. I still get the reward though. :thinking:

I’m curious. How do you know it fails? Maybe I’ve never noticed? :thinking:


#3

Oh, it just doesn’t allow you to click it. It doesn’t look a certain way, the button or text on it is not greyed out, but it won’t click. I tried leaving the phone aside for a minute on the collect reward screen, in case the adds come back, but still nothing happened when I clicked the button, so I just exited the window without collecting reward II.


#4

I’ve had that problem sometimes, but I’m pretty sure it’s bad cell service on my end. If I wait a few minutes or change spots the ad option will light up and be clickable again.


#5

Seems like a good theory!


#6

Not an internet issue in my case. I have great connection 4g everywhere in the city and I’m only on wi-fi at home, where again, very stable and fast internet. If I finish the adds in the morning, I do get a few more later in the day sometimes, didn’t really figure out how it works… I’ll try to count them I guess, on some other day, already viewed some today.


#7

@FitAari

Do the videos only fail in the fitness screen? Or can the videos fail in other places too (like the videos that give you 10 crystals)?

Might help them track the problem down if they know. :thinking:


#8

They don’t exactly fail, more like don’t start. Also, when this happens, there are no adds in the Freebies area, like my account is out of adds. A few adds do reappear during the day, when I had the app closed for a few hours or when I swap accounts back and forth.


#9

It does sound like you are running out of ads. It would not be the first time I’ve seen this happen in a game. I remember some players complaining in some other game I was playing quite a few years ago.

I also found this for the Unity game engine. I don’t think this game uses that game engine, but they do explain why it might happen there.

For most of Europe and North America, ad availability is typically not an issue. In countries where fill may be somewhat limited, the effects of this can be more obvious. For instance, if there are only 12 ad campaigns available in a user’s country, they can only see a maximum of 12 ad campaigns in a given period of time.

Sounds very similar to what you seem to be experiencing. :thinking:


#10

Chiming in because I’ve also experienced this.

I’ve had issues in this and other games where ads are not loaded immediately after opening the game and I have to wait a good five minutes to actually claim my fit energy if I want to get the ad bonus. It’s an issue in just about every new idle game I’ve played recently.

I live in an urban area, but occasionally end up in heavy traffic wifi or cell coverage holes.