Arena won’t open in fitland server

Is this happening to anyone else?
It says new but then gives me this message.

I’m not sure if it is just a weird coincidence but all my problems happen in this server.

  1. Being put in the zzz league
  2. The dark rush quit early 2 times
  3. This ?

Everything is cool :sunglasses: over in fit tower!

Yes! I was just coming here to post the same thing!

Game ID: zpgw6r

It’s my FitTower account I have problems with though, nothing odd has happened with my Fitland account until this. You and I are definitely helping to work out a lot of bugs!

My Fitland account has the same issue. Arena won’t open.
The account is rgpewq

Still same message
Here is my game id

I’m getting the same error. Could be that my kids were mucking around with my team?

Hi guys, arena is now opened.

1 Like

Too late…
When I switched between the servers to see if FitTower is the same with the arena issue.
I accidentally erased the progress save in Fitland…

Got to play from zero again… sad

Your progress isn’t lost @Kk098a, you’ve just created a second account. Switch back to the Fitland server and all your data should still be there.

Thank you radiocricket.
But it is lost.
Please note that when game asking save conflict. If you choose to keep the local save rather than the cloud, the cloud saves on “both servers” will be removed.
I just tried to reinstall game and thought that I don’t need the save on FitTower.
One press and both saves are good as new…

1 Like

:slightly_frowning_face: That’s so unfortunate @Kk098a, hopefully @marspark has a way to restore your data.

Hi @Kk098a if you happen to choose local rather than cloud, it should just replace the data from that single server. Can I please grab your game id so we can have a look?

Hi Marspark

Fitland ID:rgpewq
Fittower ID: r97x3v

If it is possible, please just recover the data for my Fitland.
I restarted game at FitTower these days. I would like to keep the current progress at FitTower to try other combinations.

Thank you

I did the same thing as kk098a. Can I get my old save back? @marspark my id is k2j6mp